The most recent version of Google Chrome or MS Edge is needed when testing on your desktop computer.

If you already have Chrome or MS Edge installed, you can check if you are running the most recent version here!


***Please note: The Validately extensions come from the Google Store. If you are using MS Edge and need to install Validately's extension, you will need to permit Edge to use extensions from other stores:


Keywords:  browser, version, Chrome, Edge, desktop, PC, devices, install, extension

Did this answer your question?